#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^1[3-9]你好\d{1,9}去$"
Local $sString = "abcdefg1234567890" & @CRLF & _
"你好" & @CRLF & _
"19你好83489去" & @CRLF & _
"14你好2去" & @CRLF & _
"19你好807974919去" & @CRLF & _
"23你好787361898去" & @CRLF & _
"18你好378972939去" & @CRLF & _
"12你好837834659去" & @CRLF & _
"18你好747593638去"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")