import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^1[3-9]你好\\d{1,9}去$";
final String string = "abcdefg1234567890\n"
+ "你好\n"
+ "19你好83489去\n"
+ "14你好2去\n"
+ "19你好807974919去\n"
+ "23你好787361898去\n"
+ "18你好378972939去\n"
+ "12你好837834659去\n"
+ "18你好747593638去";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}