import re
regex = re.compile(r"^1[3-9]你好\d{1,9}去$", flags=re.MULTILINE)
test_str = ("abcdefg1234567890\n"
"你好\n"
"19你好83489去\n"
"14你好2去\n"
"19你好807974919去\n"
"23你好787361898去\n"
"18你好378972939去\n"
"12你好837834659去\n"
"18你好747593638去")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")