use strict;
my $str = '<ok date="1578334440" motive="1.5.4. Невыплата штрафа" res="21/8000/1214657702" udo="0/0" />';
my $regex = qr~motive="(.+?)" res="(\d+/\d+)/(\d+)"~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}