# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(BB(?:\|\d){4,6}\|[^\s|]{3}\|[^\s|]{4}\|)9{2,9}\|9{2,9}(?!\d)/\g<1>12|21/gm;t' <<< "XX=BB|3|3|1|1|PLP|KLWE|9999|9999
XX=BB|3|3|1|1|2|PLP|KPOK|99999|99999
999|999|999|9999|999"