using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(BB(?:\|\d){4,6}\|[^\s|]{3}\|[^\s|]{4}\|)9{2,9}\|9{2,9}(?!\d)";
string substitution = @"\g<1>12|21";
string input = @"XX=BB|3|3|1|1|PLP|KLWE|9999|9999
XX=BB|3|3|1|1|2|PLP|KPOK|99999|99999
999|999|999|9999|999";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}