#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(BB(?:\|\d){4,6}\|[^\s|]{3}\|[^\s|]{4}\|)9{2,9}\|9{2,9}(?!\d)"
Local $sString = "XX=BB|3|3|1|1|PLP|KLWE|9999|9999" & @CRLF & _
"XX=BB|3|3|1|1|2|PLP|KPOK|99999|99999" & @CRLF & _
"999|999|999|9999|999"
Local $sSubst = "\g<1>12|21"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)