use strict;
my $str = 'XX=BB|3|3|1|1|PLP|KLWE|9999|9999
XX=BB|3|3|1|1|2|PLP|KPOK|99999|99999
999|999|999|9999|999';
my $regex = qr/(BB(?:\|\d){4,6}\|[^\s|]{3}\|[^\s|]{4}\|)9{2,9}\|9{2,9}(?!\d)/mp;
my $subst = '\\g<1>12|21';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";