# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\?v=(.+?)&.+/$1/gm;t' <<< "https://www.youtube.com/watch?v=SEkUienM2oY&t=1265s
https://m.youtube.com/watch?v=SEkUienM2oY&t=1265s
"