re = /.*\?v=(.+?)&.+/m
str = 'https://www.youtube.com/watch?v=SEkUienM2oY&t=1265s
https://m.youtube.com/watch?v=SEkUienM2oY&t=1265s
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result