use strict;
my $str = 'https://www.youtube.com/watch?v=SEkUienM2oY&t=1265s
https://m.youtube.com/watch?v=SEkUienM2oY&t=1265s
';
my $regex = qr/.*\?v=(.+?)&.+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";