import re
regex = re.compile(r".*\?v=(.+?)&.+", flags=re.MULTILINE)
test_str = ("https://www.youtube.com/watch?v=SEkUienM2oY&t=1265s\n"
"https://m.youtube.com/watch?v=SEkUienM2oY&t=1265s\n\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)