using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\?v=(.+?)&.+";
string substitution = @"$1";
string input = @"https://www.youtube.com/watch?v=SEkUienM2oY&t=1265s
https://m.youtube.com/watch?v=SEkUienM2oY&t=1265s
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}