#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.+(?:\b[Dd]ebug\b|\b[Rr]elease\b)\\(.+(?:(?:(?:[Uu]nit)?[Tt]ests)\.dll))$"
Local $sString = "C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Debug\TestProject.API.Manager.Tests.dll" & @CRLF & _
"C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Release\TestProject.API.Manager.Tests.dll" & @CRLF & _
"" & @CRLF & _
"C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\Debug\TestProject.API.Manager.UnitTests.dll" & @CRLF & _
"C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\Release\TestProject.API.Manager.UnitTests.dll" & @CRLF & _
"" & @CRLF & _
"C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Release\TestProject.API.Manager.NoName.dll" & @CRLF & _
"C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\OtherFolder\TestProject.API.Manager.Tests.dll" & @CRLF & _
"C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\ReleaseDebug\TestProject.API.Manager.Tests.dll" & @CRLF & _
"C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\DebugRelease\TestProject.API.Manager.Tests.dll" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")