// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.+(?:\b[Dd]ebug\b|\b[Rr]elease\b)\\(.+(?:(?:(?:[Uu]nit)?[Tt]ests)\.dll))$").unwrap();
let string = "C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Debug\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Release\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Debug\\TestProject.API.Manager.UnitTests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Release\\TestProject.API.Manager.UnitTests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Release\\TestProject.API.Manager.NoName.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\OtherFolder\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\ReleaseDebug\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\DebugRelease\\TestProject.API.Manager.Tests.dll
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}