use strict;
my $str = 'C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Debug\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Release\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Debug\\TestProject.API.Manager.UnitTests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Release\\TestProject.API.Manager.UnitTests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Release\\TestProject.API.Manager.NoName.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\OtherFolder\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\ReleaseDebug\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\DebugRelease\\TestProject.API.Manager.Tests.dll
';
my $regex = qr/^.+(?:\b[Dd]ebug\b|\b[Rr]elease\b)\\(.+(?:(?:(?:[Uu]nit)?[Tt]ests)\.dll))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}