using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+(?:\b[Dd]ebug\b|\b[Rr]elease\b)\\(.+(?:(?:(?:[Uu]nit)?[Tt]ests)\.dll))$";
string input = @"C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Debug\TestProject.API.Manager.Tests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Release\TestProject.API.Manager.Tests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\Debug\TestProject.API.Manager.UnitTests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\Release\TestProject.API.Manager.UnitTests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Release\TestProject.API.Manager.NoName.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\OtherFolder\TestProject.API.Manager.Tests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\ReleaseDebug\TestProject.API.Manager.Tests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\DebugRelease\TestProject.API.Manager.Tests.dll
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}