const regex = /^.+(?:\b[Dd]ebug\b|\b[Rr]elease\b)\\(.+(?:(?:(?:[Uu]nit)?[Tt]ests)\.dll))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.+(?:\\b[Dd]ebug\\b|\\b[Rr]elease\\b)\\\\(.+(?:(?:(?:[Uu]nit)?[Tt]ests)\\.dll))$', 'gm')
const str = `C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Debug\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Release\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Debug\\TestProject.API.Manager.UnitTests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Release\\TestProject.API.Manager.UnitTests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Release\\TestProject.API.Manager.NoName.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\OtherFolder\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\ReleaseDebug\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\DebugRelease\\TestProject.API.Manager.Tests.dll
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}