$re = '/^.+(?:\b[Dd]ebug\b|\b[Rr]elease\b)\\\\(.+(?:(?:(?:[Uu]nit)?[Tt]ests)\.dll))$/m';
$str = 'C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Debug\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Release\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Debug\\TestProject.API.Manager.UnitTests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Release\\TestProject.API.Manager.UnitTests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Release\\TestProject.API.Manager.NoName.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\OtherFolder\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\ReleaseDebug\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\DebugRelease\\TestProject.API.Manager.Tests.dll
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);