// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(^\w+)").unwrap();
let string = "While the patient had received travel vaccinations in preparation for a trip to India two years ago, it was not immediately certain that he received the meningococcal vaccine.
Investigation is ongoing, and this report will be updated as more information becomes available.
Reported by:
?lvaro Mej?a-Echeverry";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}