#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[vn]\.?\s*(C(hr?)?\.?|(Z(tr?)?\.?))"
Local $sString = "vc" & @CRLF & _
"vc." & @CRLF & _
"vch" & @CRLF & _
"vchr" & @CRLF & _
"v.C" & @CRLF & _
"v.C." & @CRLF & _
"v. Ch" & @CRLF & _
"v. Ch." & @CRLF & _
"v. Chr.↵" & @CRLF & _
"" & @CRLF & _
"vz" & @CRLF & _
"vz." & @CRLF & _
"vzt" & @CRLF & _
"vztr" & @CRLF & _
"v.Z" & @CRLF & _
"v.Z." & @CRLF & _
"v. Zt" & @CRLF & _
"v. Zt." & @CRLF & _
"v. Ztr.↵" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")