# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[vn]\.?\s*(C(hr?)?\.?|(Z(tr?)?\.?))"
test_str = ("vc\n"
"vc.\n"
"vch\n"
"vchr\n"
"v.C\n"
"v.C.\n"
"v. Ch\n"
"v. Ch.\n"
"v. Chr.↵\n\n"
"vz\n"
"vz.\n"
"vzt\n"
"vztr\n"
"v.Z\n"
"v.Z.\n"
"v. Zt\n"
"v. Zt.\n"
"v. Ztr.↵\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.