use strict;
my $str = 'vc
vc.
vch
vchr
v.C
v.C.
v. Ch
v. Ch.
v. Chr.↵
vz
vz.
vzt
vztr
v.Z
v.Z.
v. Zt
v. Zt.
v. Ztr.↵
';
my $regex = qr/[vn]\.?\s*(C(hr?)?\.?|(Z(tr?)?\.?))/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}