using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[vn]\.?\s*(C(hr?)?\.?|(Z(tr?)?\.?))";
string input = @"vc
vc.
vch
vchr
v.C
v.C.
v. Ch
v. Ch.
v. Chr.↵
vz
vz.
vzt
vztr
v.Z
v.Z.
v. Zt
v. Zt.
v. Ztr.↵
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}