$re = '/[vn]\.?\s*(C(hr?)?\.?|(Z(tr?)?\.?))/mi';
$str = 'vc
vc.
vch
vchr
v.C
v.C.
v. Ch
v. Ch.
v. Chr.↵
vz
vz.
vzt
vztr
v.Z
v.Z.
v. Zt
v. Zt.
v. Ztr.↵
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);