import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[vn]\\.?\\s*(C(hr?)?\\.?|(Z(tr?)?\\.?))";
final String string = "vc\n"
+ "vc.\n"
+ "vch\n"
+ "vchr\n"
+ "v.C\n"
+ "v.C.\n"
+ "v. Ch\n"
+ "v. Ch.\n"
+ "v. Chr.↵\n\n"
+ "vz\n"
+ "vz.\n"
+ "vzt\n"
+ "vztr\n"
+ "v.Z\n"
+ "v.Z.\n"
+ "v. Zt\n"
+ "v. Zt.\n"
+ "v. Ztr.↵\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}