#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^#[a-f0-9]{6}(?:,\s*#[a-f0-9]{6})?$"
Local $sString = "rgb(255,0,24)" & @CRLF & _
"rgb(255, 0, 24)" & @CRLF & _
"rgba(255, 0, 24, .5)" & @CRLF & _
"hsla(170, 23%, 25%, 0.2 )" & @CRLF & _
"#fff" & @CRLF & _
"#f2ewq" & @CRLF & _
"#0f243e" & @CRLF & _
"#0f243e,#3f54ae" & @CRLF & _
"#0f243eпп" & @CRLF & _
"#0f243eбб,#3f54aeпп" & @CRLF & _
"0x00ffff" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")