package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^#[a-f0-9]{6}(?:,\s*#[a-f0-9]{6})?$`)
var str = `rgb(255,0,24)
rgb(255, 0, 24)
rgba(255, 0, 24, .5)
hsla(170, 23%, 25%, 0.2 )
#fff
#f2ewq
#0f243e
#0f243e,#3f54ae
#0f243eпп
#0f243eбб,#3f54aeпп
0x00ffff
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}