// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^#[a-f0-9]{6}(?:,\s*#[a-f0-9]{6})?$").unwrap();
let string = "rgb(255,0,24)
rgb(255, 0, 24)
rgba(255, 0, 24, .5)
hsla(170, 23%, 25%, 0.2 )
#fff
#f2ewq
#0f243e
#0f243e,#3f54ae
#0f243eпп
#0f243eбб,#3f54aeпп
0x00ffff
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}