# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^#[a-f0-9]{6}(?:,\s*#[a-f0-9]{6})?$"
test_str = ("rgb(255,0,24)\n"
"rgb(255, 0, 24)\n"
"rgba(255, 0, 24, .5)\n"
"hsla(170, 23%, 25%, 0.2 )\n"
"#fff\n"
"#f2ewq\n"
"#0f243e\n"
"#0f243e,#3f54ae\n"
"#0f243eпп\n"
"#0f243eбб,#3f54aeпп\n"
"0x00ffff\n")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.