# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<=\<)[^>]+style=")([^>"]+)/$1$2margin:0;/gmiu;t' <<< "<p id=\"tem\" style=\"text-align: justify;\"><span style=\"font-size: 11pt;\" >hello world<br /></span></p>
<p style=\"text-align: justify;\">test text-align: justify;</p> style=\"text-align: justify;\"
<p > </p>
<p> </p>"