re = /((?<=\<)[^>]+style=")([^>"]+)/mi
str = '<p id="tem" style="text-align: justify;"><span style="font-size: 11pt;" >hello world<br /></span></p>
<p style="text-align: justify;">test text-align: justify;</p> style="text-align: justify;"
<p > </p>
<p> </p>'
subst = '$1$2margin:0;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result