import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"((?<=\<)[^>]+style=")([^>"]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<p id="tem" style="text-align: justify;"><span style="font-size: 11pt;" >hello world<br /></span></p>
<p style="text-align: justify;">test text-align: justify;</p> style="text-align: justify;"
<p > </p>
<p> </p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2margin:0;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)