using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=\<)[^>]+style="")([^>""]+)";
string substitution = @"$1$2margin:0;";
string input = @"<p id=""tem"" style=""text-align: justify;""><span style=""font-size: 11pt;"" >hello world<br /></span></p>
<p style=""text-align: justify;"">test text-align: justify;</p> style=""text-align: justify;""
<p > </p>
<p> </p>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}