import re
regex = re.compile(r"((?<=\<)[^>]+style=\")([^>\"]+)", flags=re.MULTILINE | re.IGNORECASE | re.UNICODE)
test_str = ("<p id=\"tem\" style=\"text-align: justify;\"><span style=\"font-size: 11pt;\" >hello world<br /></span></p>\n"
"<p style=\"text-align: justify;\">test text-align: justify;</p> style=\"text-align: justify;\"\n"
"<p > </p>\n"
"<p> </p>")
subst = "$1$2margin:0;"
result = regex.sub(subst, test_str)
if result:
print(result)