package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)actuals_ADAPS_20150517_3\.t><\/A>\s*(.*?)\s*4k`)
var str = `<A HREF="actuals_ADAPS_20150517_3.txt"></A> <A HREF="actuals_ADAPS_20150517_3.txt">actuals_ADAPS_20150517_3.t></A> May 17 00:50 4k <A HREF="actuals_ADAPS_20150518_1.txt"></A> <A HREF="actuals_ADAPS_20150518_1.txt">actuals_ADAPS_20150518_1.t></A> May 17 18:50 4k <A HREF="actuals_ADAPS_20150518_3.txt"></A> <A HREF="actuals_ADAPS_20150518_3.txt">actuals_ADAPS_20150518_3.t></A> May 18 00:50 4k`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}