// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)actuals_ADAPS_20150517_3\.t><\/A>\s*(.*?)\s*4k").unwrap();
let string = "<A HREF=\"actuals_ADAPS_20150517_3.txt\"></A> <A HREF=\"actuals_ADAPS_20150517_3.txt\">actuals_ADAPS_20150517_3.t></A> May 17 00:50 4k <A HREF=\"actuals_ADAPS_20150518_1.txt\"></A> <A HREF=\"actuals_ADAPS_20150518_1.txt\">actuals_ADAPS_20150518_1.t></A> May 17 18:50 4k <A HREF=\"actuals_ADAPS_20150518_3.txt\"></A> <A HREF=\"actuals_ADAPS_20150518_3.txt\">actuals_ADAPS_20150518_3.t></A> May 18 00:50 4k";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}