import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "actuals_ADAPS_20150517_3\\.t><\\/A>\\s*(.*?)\\s*4k";
final String string = "<A HREF=\"actuals_ADAPS_20150517_3.txt\"></A> <A HREF=\"actuals_ADAPS_20150517_3.txt\">actuals_ADAPS_20150517_3.t></A> May 17 00:50 4k <A HREF=\"actuals_ADAPS_20150518_1.txt\"></A> <A HREF=\"actuals_ADAPS_20150518_1.txt\">actuals_ADAPS_20150518_1.t></A> May 17 18:50 4k <A HREF=\"actuals_ADAPS_20150518_3.txt\"></A> <A HREF=\"actuals_ADAPS_20150518_3.txt\">actuals_ADAPS_20150518_3.t></A> May 18 00:50 4k";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}