use strict;
my $str = '<A HREF="actuals_ADAPS_20150517_3.txt"></A> <A HREF="actuals_ADAPS_20150517_3.txt">actuals_ADAPS_20150517_3.t></A> May 17 00:50 4k <A HREF="actuals_ADAPS_20150518_1.txt"></A> <A HREF="actuals_ADAPS_20150518_1.txt">actuals_ADAPS_20150518_1.t></A> May 17 18:50 4k <A HREF="actuals_ADAPS_20150518_3.txt"></A> <A HREF="actuals_ADAPS_20150518_3.txt">actuals_ADAPS_20150518_3.t></A> May 18 00:50 4k';
my $regex = qr/actuals_ADAPS_20150517_3\.t><\/A>\s*(.*?)\s*4k/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}