$re = '/actuals_ADAPS_20150517_3\.t><\/A>\s*(.*?)\s*4k/m';
$str = '<A HREF="actuals_ADAPS_20150517_3.txt"></A> <A HREF="actuals_ADAPS_20150517_3.txt">actuals_ADAPS_20150517_3.t></A> May 17 00:50 4k <A HREF="actuals_ADAPS_20150518_1.txt"></A> <A HREF="actuals_ADAPS_20150518_1.txt">actuals_ADAPS_20150518_1.t></A> May 17 18:50 4k <A HREF="actuals_ADAPS_20150518_3.txt"></A> <A HREF="actuals_ADAPS_20150518_3.txt">actuals_ADAPS_20150518_3.t></A> May 18 00:50 4k';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);