import re
regex = re.compile(r"(?:([a-z]{2,})_)?(\d+)_([a-z]{2,}\d+)_(\d+)$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("SH_6208069141055_BC000388_20110412101855\n"
"6208069141055_BC000388_20110412101855")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")