// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(?:([a-z]{2,})_)?(\d+)_([a-z]{2,}\d+)_(\d+)$").unwrap();
let string = "SH_6208069141055_BC000388_20110412101855
6208069141055_BC000388_20110412101855";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}