re = /(?:([a-z]{2,})_)?(\d+)_([a-z]{2,}\d+)_(\d+)$/im
str = 'SH_6208069141055_BC000388_20110412101855
6208069141055_BC000388_20110412101855'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end