#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/(?: +[^\/\s]+)*\/ [^\/\s]+(?: +[^\/\s]+)*\/$"
Local $sString = "/Volumes/SAMPLES/ VOCALS/" & @CRLF & _
"/Volumes/SAMPLES/ VOCALS/ AFRICA/" & @CRLF & _
"=> /Volumes/SAMPLES/ VOCALS/ AcmeInc Club Vocals/" & @CRLF & _
"/Volumes/SAMPLES/ VOCALS/ AtomicInc Dance Vocals/" & @CRLF & _
"/Volumes/SAMPLES/ VOCALS/ AFRICA/ AfroInc Zulu Vocals/" & @CRLF & _
"/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/" & @CRLF & _
"/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/SampleInc_Warriors_Ululation/" & @CRLF & _
"/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/SampleInc_Warriors_Drums/" & @CRLF & _
"/Volumes/SAMPLES/ VOCALS/ AFRICA/ AfroInc Zulu Vocals/ Folder1/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")