using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(?: +[^\/\s]+)*\/ [^\/\s]+(?: +[^\/\s]+)*\/$";
string input = @"/Volumes/SAMPLES/ VOCALS/
/Volumes/SAMPLES/ VOCALS/ AFRICA/
=> /Volumes/SAMPLES/ VOCALS/ AcmeInc Club Vocals/
/Volumes/SAMPLES/ VOCALS/ AtomicInc Dance Vocals/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ AfroInc Zulu Vocals/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/SampleInc_Warriors_Ululation/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/SampleInc_Warriors_Drums/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ AfroInc Zulu Vocals/ Folder1/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}