const regex = /\/(?: +[^\/\s]+)*\/ [^\/\s]+(?: +[^\/\s]+)*\/$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(?: +[^\\\/\\s]+)*\\\/ [^\\\/\\s]+(?: +[^\\\/\\s]+)*\\\/$', 'mg')
const str = `/Volumes/SAMPLES/ VOCALS/
/Volumes/SAMPLES/ VOCALS/ AFRICA/
=> /Volumes/SAMPLES/ VOCALS/ AcmeInc Club Vocals/
/Volumes/SAMPLES/ VOCALS/ AtomicInc Dance Vocals/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ AfroInc Zulu Vocals/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/SampleInc_Warriors_Ululation/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/SampleInc_Warriors_Drums/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ AfroInc Zulu Vocals/ Folder1/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}