import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/(?: +[^\\/\\s]+)*\\/ [^\\/\\s]+(?: +[^\\/\\s]+)*\\/$";
final String string = "/Volumes/SAMPLES/ VOCALS/\n"
+ "/Volumes/SAMPLES/ VOCALS/ AFRICA/\n"
+ "=> /Volumes/SAMPLES/ VOCALS/ AcmeInc Club Vocals/\n"
+ "/Volumes/SAMPLES/ VOCALS/ AtomicInc Dance Vocals/\n"
+ "/Volumes/SAMPLES/ VOCALS/ AFRICA/ AfroInc Zulu Vocals/\n"
+ "/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/\n"
+ "/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/SampleInc_Warriors_Ululation/\n"
+ "/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/SampleInc_Warriors_Drums/\n"
+ "/Volumes/SAMPLES/ VOCALS/ AFRICA/ AfroInc Zulu Vocals/ Folder1/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}