import Foundation
let pattern = #"\/(?: +[^\/\s]+)*\/ [^\/\s]+(?: +[^\/\s]+)*\/$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/Volumes/SAMPLES/ VOCALS/
/Volumes/SAMPLES/ VOCALS/ AFRICA/
=> /Volumes/SAMPLES/ VOCALS/ AcmeInc Club Vocals/
/Volumes/SAMPLES/ VOCALS/ AtomicInc Dance Vocals/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ AfroInc Zulu Vocals/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/SampleInc_Warriors_Ululation/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/SampleInc_Warriors_Drums/
/Volumes/SAMPLES/ VOCALS/ AFRICA/ AfroInc Zulu Vocals/ Folder1/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)