import re
regex = re.compile(r"\/(?: +[^\/\s]+)*\/ [^\/\s]+(?: +[^\/\s]+)*\/$", flags=re.MULTILINE)
test_str = ("/Volumes/SAMPLES/ VOCALS/\n"
"/Volumes/SAMPLES/ VOCALS/ AFRICA/\n"
"=> /Volumes/SAMPLES/ VOCALS/ AcmeInc Club Vocals/\n"
"/Volumes/SAMPLES/ VOCALS/ AtomicInc Dance Vocals/\n"
"/Volumes/SAMPLES/ VOCALS/ AFRICA/ AfroInc Zulu Vocals/\n"
"/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/\n"
"/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/SampleInc_Warriors_Ululation/\n"
"/Volumes/SAMPLES/ VOCALS/ AFRICA/ SampleInc Warriors/SampleInc_Warriors_Drums/\n"
"/Volumes/SAMPLES/ VOCALS/ AFRICA/ AfroInc Zulu Vocals/ Folder1/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")