#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(-I.*?(?="))"
Local $sString = "1334 execve("/home/y/bin64/ccache", ["/home/y/bin64/ccache", "/usr/bin/g++", "-fPIC", "-g", "-O2", "-Wall", "-pipe", "-MD", "-MP", "-D_REENTRANT", "-DLINUX", "-D_GNU_SOURCE", "-D_THREAD_SAFE", "-DUSE_STD_YUTSTRING", "-DNO_FACTORY", "-I/home/lniu/component/.build/include", "-I../include/", "-I../include/sample/", "-I/home/include64", "-I/home/include", "-I/home/lniu/sample", "-I/home/lniu/sample/../libraries", "-o", "x86_64-linux-gcc/sample"], [/* 63 vars */]) = 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")